文档反馈
文档反馈

集成SDK(Flutter)

本文为您介绍了 Flutter 端集成 NERTC SDK 的操作步骤,帮助您快速集成 SDK 并实现互动直播的基本功能。

前提条件

在开始运行工程之前,请您准备以下开发环境:

集成 SDK

NERTC Flutter SDK 已正式发布到 pub.dev ,您可以在 pub 库中查询最新版本,通过配置 pubspec.yaml 自动下载更新。

添加依赖项

在项目的 pubspec.yaml 中添加以下依赖:

dependencies:
# NERtc SDK 依赖项,请使用最新版本的 nertc
nertc:​ ^3.9.0

开通摄像头和麦克风的权限

通过 Flutter SDK 实现音视频通话之前,需要放开摄像头和麦克风的使用权限,以开启视频和语音通话功能。

实现互动直播

×

反馈成功

非常感谢您的反馈,我们会继续努力做得更好。